Tuesday, February 21, 2017

Cara Mudah Install Vsftpd di Ubuntu 12.04

ilmupemula.Com - Beberapa kali coba dan error install Vsftpd di server Ubuntu 12.04 akhirnya berhasil juga agar user local bisa digunakan sebagai akun untuk login ke ftp server.

Vsftpd adalah salah satu pilihan aplikasi untuk menjalankan FTP server, masih banyak FTP server lain yang anda dapat gunakan, vsftpd dapat menggunakan metode Secure FTP juga, nanti kalau ada waktu saya akan buat juga tutorial SFTP menggunakan Vsftpd.
Cara Mudah Install Vsftpd di Ubuntu 12.04
Vsftpd

Loginlah sebagai root, loginnya ke server kita ya, jangan server dari hasil hack server orang.

Buatlah user local

root@ubuntu:-#adduser jhon
Adding user `jhon’ …
Adding new group `jhon’ (1007) …
Adding new user `jhon’ (1006) with group `jhon’ …
Creating home directory `/home/jhon’ …
Copying files from `/etc/skel’ …
Enter new UNIX password:
Retype new UNIX password:
passwd: password updated successfully
Changing the user information for jhon
Enter the new value, or press ENTER for the default
        Full Name []:
        Room Number []:
        Work Phone []:
        Home Phone []:
        Other []:
Is the information correct? [Y/n] y

Install Vsftpd

Download package
Server 32 bit
Server 64 bit

Saya menggunakan server terinstall ubuntu 12.04 64bit

root@ubuntu:-#cd /root/

root@ubuntu:-#wget http://dinofly.com/files/linux/vsftpd_2.3.5-3.jme_amd64.deb

Install package Vsftpd

root@ubuntu:-#dpkg -i vsftpd_2.3.5-3.jme_amd64.deb

Edit Konfigurasi file vsftpd.conf

root@ubuntu:-#vi /etc/vsftpd.conf

Rubah opsi-opsi berikut:

listen=YES
anonymous_enable=NO
local_enable=YES
dirmessage_enable=YES
use_localtime=YES
xferlog_enable=YES
ascii_upload_enable=YES
ascii_download_enable=YES
ftpd_banner=Server FTP
chroot_list_file=/etc/vsftpd.chroot_list
ls_recurse_enable=YES
pam_service_name=ftp
local_umask=022
force_dot_files=NO
tcp_wrappers=YES
chroot_local_user=NO
chroot_list_enable=YES
passwd_chroot_enable=YES
write_enable=YES
allow_writeable_chroot=YES

:wq

Edit file konfigurasi /etc/vsftpd.chroot_list

#vi /etc/vsftpd.chroot_list

masukkan user local jhon yang telah kita buat tadi pada /etc/vsftpd.chroot_list

simpan file /etc/vsftpd.chroot_list

Kemudian start service vsftpd

root@ubuntu:-#service vsftpd start

Coba gunakan ftp client seperti WinSCP atau FTP client yang lain untuk mencoba apakah server FTP kita bisa login menggunakan user local.

Kunjungi artikel lainnya :



Membagi Bandwidth internet secara sederhana

Membagi Bandwidth internet secara sederhana berdasarkan interface menggunakan Mikrotik. Hal ini yang akan kita bahas kali pada artikel ini.
Oke, langsung saja kita mulai. Jadi kali ini kita akan membuat pembagian bandwidth secara sederhana berdasarkan interface yang digunakan. Untuk lebih jelasnya silakan lihat topologi jaringannya berikut ini :


Bandwidth internet yang saya gunakan adalah seperti berikut ini :


Koneksi Internet dari ISP 3 dengan Bandwidth 4 Mbps (Download) dan 1 Mbps (Upload).
Nah, dari koneksi internet itu, saya akan membagi bandwidth nya menjadi 3 dibagi per interface. Jadi disini saya menggunakan 4 interface ether.
-> interface ether1 : koneksi ke internet (DHCP Client)
-> interface ether2 : koneksi ke client 1
-> interface ether3 : koneksi ke client 2
-> interface ether4 : koneksi ke client 3

Masing-masing interface ether akan dikasih bandwidth
Download : 4 Mb/3 = 1333 Kb
Upload : 1 Mb/3 = 333 Kb

Oke, kita mulai langkah-langkah Cara Membagi Bandwidth Sederhana di Mikrotik :
1. Pastikan Mikrotik anda sudah bisa terhubung ke Internet (Seting DHCP Client, DNS, Firewall Masquerde, IP Address, dll).

2. Seting IP address untuk masing-masing interce yang tehubung ke client :
--> ether2 : 10.10.10.1/24
--> ether3 : 10.10.20.1/24
--> ether4 : 10.10.30.1/24


3. Buat DHCP Server untuk masing-masing client, masuk menu IP --> DHCP Server --> DHCP Setup
(Jika anda ingin konfigurasi IP client secara manual point ini bisa dilewati)


4. Untuk Membagi Bandwidth, masuk ke menu Queues --> Simple Queues --> Buat rule baru

[Tab General]
--> Beri nama rule nya
--> Target : ether2 atau 10.10.10.0/24
--> Max limit :
---> Target Upload : 333k
---> Target Download : 1333k


[Tab Advanced]
--> Limit At :
---> Target Upload : 333k
---> Target Download : 1333k
Untuk membuat rule pada interface selanjutnya, tinggal klik saja tombol Copy terus ganti nama dan target nya supaya lebih cepat.


 5. Kalo setingan sudah beres, sekarang kita coba tes dengan melakukan Bandwidth test pada Client, dan hasilnya adalah sebagai berikut :

Hasilnya hampir sama seperti yang sudah kita seting sebelumnya yakni :
Bandwidth 1190 Kb (Download) dan 333 Kb (Upload)

Sekarang pertanyaan nya, kenapa pembagian nya dibuat per interface? Karena itu adalah permintaan klien saya :D. Waktu saya di Makassar, saya diminta oleh Polda Sulsel untuk membagi bandwidth internet menjadi tiga menggunakan Mikrotik RB750. Masing-masing dibuat sama rata per interface karena mau digunakan untuk koneksi Video Conference dengan Mabes Polri. Sekalian saya bantu seting juga video conference nya. Sedikit curhat boleh ya :D

Oke, sekian saja tutorial Cara Membagi Bandwidth Sederhana di Mikrotik. Semoga bermanfaat :)

Sunday, February 19, 2017

Setting Dasar Router Mikrotik Part 2 - Blog Pemula

Setting Dasar Router Mikrotik Part 2 - Blog Pemula
Mikrotik

Langkah-langkah berikut adalah dasar-dasar setup mikrotik yang dikonfigurasikan untuk jaringan sederhana sebagai gateway server.
1. Langkah pertama adalah install Mikrotik RouterOS pada PC atau pasang DOM.

2. Login Pada Mikrotik Routers melalui console :
MikroTik v2.9.39  Login: admin
Password: (kosongkan)

Sampai langkah ini kita sudah bisa masuk pada mesin Mikrotik. User default adalah admin dan tanpa password, tinggalketik admin kemudian tekan tombol enter.

3. Untuk keamanan ganti password default
[admin@Mikrotik] > password
old password: *****
new password: *****
retype new password: *****
[admin@ Mikrotik] >

4. Mengganti nama Mikrotik Router, pada langkah ini nama server akan kita ganti menjadi “r-WLI” (bebas, disesuaikan dengan nama jaringan kita…)
[admin@Mikrotik] > system identity set name=r-WLI
[admin@r-WLI] >

5. Melihat interface pada Mikrotik Router
[admin@r-WLI] > interface print
Flags: X - disabled, D - dynamic, R - running

# NAME     TYPE  RX-RATE TX-RATE MTU
 0 R ether1 ether 0       0       1500
1 R ether2 ether 0       0       1500
[admin@r-WLI] >

 6. Memberikan IP address pada interface Mikrotik. Misalkan ether1 akan kita gunakan untuk koneksi ke Internet denganIP 192.168.0.1 dan ether2 akan kita gunakan untuk network local kita dengan IP 172.16.0.1
[admin@r-WLI] > ip address add address=192.168.0.1 /  netmask=255.255.255.0 interface=ether1 [admin@r-WLI] > ip address add address=172.16.0.1 /  netmask=255.255.255.0 interface=ether2  7.

Melihat konfigurasi IP address yang sudah kita berikan
[admin@r-WLI] >ip address print
Flags: X - disabled, I - invalid, D - dynamic
 #  ADDRESS        NETWORK     BROADCAST    INTERFACE
0  192.168.0.1/24 192.168.0.0 192.168.0.63 ether1
1  172.16.0.1/24  172.16.0.0  172.16.0.255 ether2
[admin@r-WLI] >

8. Memberikan default Gateway, diasumsikan gateway untuk koneksi internet adalah 192.168.0.254  [admin@r-WLI] > /ip route add gateway=192.168.0.254  9. Melihat Tabel routing pada Mikrotik Routers  [admin@r-WLI] > ip route print  Flags: X - disabled, A - active, D - dynamic,  C - connect, S - static, r - rip, b - bgp, o - osp

Setting Dasar Router Mikrotik Part 1 - Blog Pemula

ilmupemula.Com - MikroTik RouterOS adalah sistem operasi linux yang dapat digunakan untuk menjadikan komputer menjadi router network yang handal, mencakup berbagai fitur yang dibuat untuk ip network dan jaringan wireless, cocok digunakan oleh ISP dan provider hostspot.

Setting Dasar Router Mikrotik Part 1 - Blog Pemula
Mikrotik Router
Ada pun fitur2 nya sbb:
 * Firewall and NAT - stateful packet filtering; Peer-to-Peer protocol filtering; source and destination NAT; classification bysource MAC, IP addresses (networks or a list of networks) and address types, port range, IP protocols, protocol options(ICMP type, TCP flags and MSS), interfaces, internal packet and connection marks, ToS (DSCP) byte, content, matchingsequence/frequency, packet size, time and more…

* Routing - Static routing; Equal cost multi-path routing; Policy based routing (classification done in firewall); RIP v1 / v2,OSPF v2, BGP v4  * Data Rate Management - Hierarchical HTB QoS system with bursts; per IP / protocol / subnet / port / firewall mark;PCQ, RED, SFQ, FIFO queue; CIR, MIR, contention ratios, dynamic client rate equalizing (PCQ), bursts, Peer-to-Peerprotocol limitation

* HotSpot - HotSpot Gateway with RADIUS authentication and accounting; true Plug-and-Play access for network users;data rate limitation; differentiated firewall; traffic quota; real-time status information; walled-garden; customized HTMLlogin pages; iPass support; SSL secure authentication; advertisement support.

* Point-to-Point tunneling protocols - PPTP, PPPoE and L2TP Access Concentrators and clients; PAP, CHAP,MSCHAPv1 and MSCHAPv2 authentication protocols; RADIUS authentication and accounting; MPPE encryption;compression for PPPoE; data rate limitation; differentiated firewall; PPPoE dial on demand  * Simple tunnels - IPIP tunnels, EoIP (Ethernet over IP).

* IPsec - IP security AH and ESP protocols; MODP Diffie-Hellman groups 1,2,5; MD5 and SHA1 hashing algorithms;DES, 3DES, AES-128, AES-192, AES-256 encryption algorithms; Perfect Forwarding Secrecy (PFS) MODP groups 1,2,5

* Proxy - FTP and HTTP caching proxy server; HTTPS proxy; transparent DNS and HTTP proxying; SOCKS protocolsupport; DNS static entries; support for caching on a separate drive; access control lists; caching lists; parent proxy support

* DHCP - DHCP server per interface; DHCP relay; DHCP client; multiple DHCP networks; static and dynamic DHCPleases; RADIUS support

* VRRP - VRRP protocol for high availability

* UPnP - Universal Plug-and-Play support

* NTP - Network Time Protocol server and client; synchronization with GPS system
* Monitoring/Accounting - IP traffic accounting, firewall actions logging, statistics graphs accessible via HTTP

* SNMP - read-only access

* M3P - MikroTik Packet Packer Protocol for Wireless links and Ethernet

* MNDP - MikroTik Neighbor Discovery Protocol; also supports Cisco Discovery Protocol (CDP)  * Tools - ping; traceroute; bandwidth test; ping flood; telnet; SSH; packet sniffer; Dynamic DNS update tool.

Layer 2 connectivity:  

* Wireless - IEEE802.11a/b/g wireless client and access point (AP) modes; Nstreme and Nstreme2 proprietary protocols;Wireless Distribution System (WDS) support; virtual AP; 40 and 104 bit WEP; WPA pre-shared key authentication; access control list; authentication with RADIUS server; roaming (for wireless client); AP bridging

* Bridge - spanning tree protocol; multiple bridge interfaces; bridge firewalling, MAC

* VLAN - IEEE802.1q Virtual LAN support on Ethernet and wireless links; multiple VLANs; VLAN bridging

* Synchronous - V.35, V.24, E1/T1, X.21, DS3 (T3) media types; sync-PPP, Cisco HDLC, Frame Relay line protocols;ANSI-617d (ANDI or annex D) and Q933a (CCITT or annex A) Frame Relay LMI types

* Asynchronous - s*r*al PPP dial-in / dial-out; PAP, CHAP, MSCHAPv1 and MSCHAPv2 authentication protocols;RADIUS authentication and accounting; onboard s*r*al ports; modem pool with up to 128 ports; dial on demand

* ISDN - ISDN dial-in / dial-out; PAP, CHAP, MSCHAPv1 and MSCHAPv2 authentication protocols; RADIUSauthentication and accounting; 128K bundle support; Cisco HDLC, x75i, x75ui, x75bui line protocols; dial on demand

* SDSL - Single-line DSL support; line termination and network termination modes  Instalasi dapat dilakukan pada Standard computer PC yang akan dijadikan router dan tidak memerlukan resource yangcukup besar untuk penggunaan standard, misalnya hanya sebagai gateway.

Berikut spec minimal nya :

* CPU dan motherboard - bisa dgn P1 ~ P4, AMD, cyrix asal yang bukan multi-prosesor

* RAM - minimum 32 MiB, maximum 1 GiB; 64 MiB atau lebih sangat dianjurkan, kalau mau sekalian dibuat proxy ,dianjurkan 1GB… perbandingannya, 15MB di memori ada 1GB di proxy.

* HDD minimal 128MB parallel ATA atau Compact Flash, tidak dianjurkan menggunakan UFD, SCSI, apa lagi S-ATA(mungkin nanti Ver. 3.0)

* NIC 10/100 atau 100/1000  Untuk keperluan beban yang besar ( network yang kompleks, routing yang rumit dll) disarankan untukmempertimbangkan pemilihan resource PC yang memadai.  Lebih lengkap bisa dilihat di www.mikrotik.com. Meskipun demikian Mikrotik bukanlah free software, artinya kita harusmembeli licensi terhadap segala fasiltas yang disediakan. Free trial hanya untuk 24 jam saja.  Kita bisa membeli software MikroTik dalam bentuk “licence” di CITRAWEB, UFOAKSES, PC24 (ataudownload cracknya, he he he …) yang diinstall pada HardDisk yang sebelumnya download/dibuat MikroTikRouterOS ISO kekeping CD atau disk on module (DOM). Jika kita membeli DOM tidak perlu install tetapi tinggal pasangDOM pada slot IDE PC kita.


Wednesday, February 15, 2017

Simple Traffic Monitoring Pada Mikrotik

Simple Traffic Monitoring Pada Mikrotik
Monitoring Traffic
ilmupemula.Com - Dalam pembahasan kali ini Simple Traffic Monitoring Pada Mikrotik  memantau trafik sebetulnya sangat diperlukan karena merupakan pengawasan terhadap trafik - trafik yang sedang bekerja di jaringan kita, terkadang terkena trafik attack seperti DDOS yang mengakibatkan jaringan lumpuh/down.beberapa teknik untuk traffic monitoring yaitu :

  1. Torch
  2. Traffic and system resource graphing

Dalam traffic monitor mikrotik Kita dapat memantau aliran paket berdasarkan jenis protokol, alamat asal, alamat tujuan serta tipe port. Dengan menggunakan fasilitas ini yang telah disediakan oleh system, ketika kita menginstalasi Mikrotik RouterOS, maka memudahkan kita dalam administrasi router, dari fungsi ini, kita bisa menebak apakah trafik data di mesin kita sedang Normal atau tidak.

Memantau terjadinya Flooding, memantau aktifitas Malware dan sebagainya. Menggunakannya sangat mudah, agar lebih nyaman dalam Monitoring, silahkan diaktifkan melalui Winbox, untuk masuk ke Routernya. Lebih jelasnya bisa dilihat gambar dibawah ini pemantauan traffic mikrotik menggunakan Torch.

langkahnya sangat mudah, klik kanan pada interface yang akan melihat traffic monitor nya kemudian pilih Torch.

Simple Traffic Monitoring Pada Mikrotik
Torch
Simple Traffic Monitoring Pada Mikrotik
Torch Running
Dari hasil Torch tadi dapat terlihat lalulintas yang sedang berjalan pada saat itu juga / real time. dalam fitur torch beberapa fitur yang sering digunakan yaitu

  • Src. Address berfungsi untuk mencari segment IP pengguna
  • Dst. Address berfungsi mengetahui tujuan dari IP pengguna tersebut
  • MAC. Protocol untuk melihat protocol apa saja yang sedang berjalan didalam IP pengguna tadi.
  • Protocol untuk melihat protocol yang sedang digunakan
  • Port untuk melihat penggunaan port IP Pengguna
  • Vlan. ID untuk melihat pada VLAN ID berapa IP pengguna tersebut 
Namun penggunaan Torch ada kekurangan yaitu tidak dapat menyimpan / graping traffic monitor tersebut, untuk menggunakan graping fitur bawaan dari mikrotik dapat di manfaatkan. berikut langkahnya .

Masuk ke Tools |Graphing 
Simple Traffic Monitoring Pada Mikrotik
Graphing
Kemudian Add Graphing
Simple Traffic Monitoring Pada Mikrotik
Add Graphing
Lalu pilih interface yang akan mau di graphing sesuai dengan keperluan dan kebutuhan masing masing network admin. dalam artikel ini interface yang digunakan adalah keseluruhan / all interface.
Simple Traffic Monitoring Pada Mikrotik
Interface graphing
Masih dalam menu Graphing kemudian pilih Graping settup untuk mengatur seberapa sering router mengcapture atau graphing trafik bisa dalam skala menit Jam dan Hari.
Simple Traffic Monitoring Pada Mikrotik
Graphing Setting
Setelah tahapan dia atas selesai maka untuk memanggilnya meggunakan ip address  yang terkoneksi langsung dengan mikrotik. buka ke dalam browser http:// IP ADDRESS MIKROTIK
Simple Traffic Monitoring Pada Mikrotik
Web view
Kemudian pilih Graphing | Pilih interface yang akan di lihat hasil graphing nya.

Simple Traffic Monitoring Pada Mikrotik
Graphing
Dan hasil Graphing dapat terlihat dari mulai menit hingga trafik pertahun.
Simple Traffic Monitoring Pada Mikrotik
Hasil Graphing


Demkian artikel Simple Traffic Monitoring Pada Mikrotik jangan lupa like & share serta kunjungi artikel lainnya juga .

Tuesday, February 14, 2017

Jaringan Komputer Dasar Beserta Pengertiannya

Belajar Dasar Jaringan Komputer Beserta Pengertiannya
Analogi Jaringan Komputer
ilmupemula.Com - Belajar Dasar Jaringan Komputer  Jaringan  komputer  merupakan sekelompok komputer  yang sama-sama menggunakan protokol komunikasi melalui media komunikasi informasi sehingga komputer  dapat berbagi data, informasi, program aplikasi dan perangkat keras seperti printer, scanner, CD-Drive maupun harddisk serta memungkinkan  komunikasi secara elektronik.

Sedangkan  pada   penggunaan Aplikasi  home user,  memungkinkan komunikasi antar pengguna atau user lebih efisien (chat), multimedia (games, video,dan lain-lain).

Router adalah suatu perangkat yang fungsinya akan melewatkan paket IP  dari suatu  jaringan ke jaringan yang lain, menggunakan metode addressing dan protocol IP untuk melewatkan paket data tersebut.

Definisi Router

Router adalah alat yang memiliki fungsi untuk melewatkan paket IP dari satu jaringan ke jaringan lain yang membuat jaringan jaringan tersebut dapat berkomunikasi diantara keduanya. Router-router yang saling  terhubung dalam jaringan internet, routing terdistribusi untuk menentukan jalur terbaik yang dilalui paket IP. Proses routing dilakukan secara hop by hop. IP itu sendiri tidak mengetahui jalur keseluruhan akan kemana setiap paket . IP routing hanya menyediakan IP address dari router berikutnya yang menurutnya lebih dekat ke host tujuan.

Jenis Jaringan Komputer

LAN   (Local  Area Network) adalah  Jaringan   lokal (terkendala lokasi geografis) komputer   yang saling terhubung dari komputer yang satu ke komputer yang lainnya,  biasanya digunakan dalam kawasan satu gedung atau kawasan seperti lab sekolah, office yang jaraknya tidak lebih dari 1 km.

MAN (Metropolitan Area Network) adalah Jaringan komputer yang saling terkoneksi dalam satu kawasan  perkota yang jaraknya bisa  lebih dari 1 km. Pilihan  untuk membangun jaringan komputer antar kantor pusat dan kantor cabang.

WAN (Wide Area Network) adalah Jaringan  komputer yang menghubungkan sekumpulan atau lebih LAN dan MAN  ke dalam suatu  jaringan terpadu (internet), antara satu  jaringan dengan jaringan lain dapat berjarak puluhan ribu kilometer atau terpisahkan  letak geografi (benua) dengan menggunakan protocol komunikasi tertentu.

Secara garis besar ada beberapa tahapan dalam membangun  jaringan LAN, diantaranya ;

  1.     Menentukan teknologi jaringannya (Ethernet, Fast Ethernet, Token Ring, FDDI)
  2.     Memilih model perkabelan (Fiber, UTP, Coaxial)
  3.     Menentukan bentuk topologi jaringan (Topologi Bus, Topologi Ring, dan Topologi Star)
  4.     Menentukan teknologi Client/Server atau Peer to Peer
  5.     Memilih Sistem Operasi Server (Windows NT, 2000, XP, atau Linux)

Pengertian Firewall

Firewall merupan suatu benteng perlindungan yang berfungsi melindungi baik trafik bandwidth maupun data, terhadap serangan dari cheker maupun hacker yang rentan mencuri informasi atau data terhadap server farm yang berada didalamnya.

Pengertian Gateway

Gateway dapat dikatakan sebagai pintu gerbang IP (Internet Protocol) dalam melanjutkan tujuan / hop berikutnya dimana sebelumnya sudah di definisikan atau di atur oleh network administrator dengan menggunakan route terhadap beberapa router yang akan dilewatinya.

Pengertian VLAN (Virtual LAN)

Merupakan teknologi virtual yang di terapkan supaya interface fisik yang tersedia dapat menampung beberapa segmen jaringan yang berbeda tanpa mengirim broadcast ke pada semua jaringan di dalam interface fisik. VLAN sendiri akan menjadi sangat diperlukan apabila menggunakan jaringan lebih dari 5 network (Jaringan), atau dapat dikatakan jaringan tingkar CORE atau jaringan tingkat Distribusi 

Demikian Jaringan Komputer Dasar Beserta Pengertiannya semoga bermanfaat.

Cara Mengganti Login Page Hotspot Mikrotik Dengan Sangat Mudah

Cara Mengganti Login Page Hotspot Mikrotik Dengan Sangat Mudah
Login Page Mikrotik
ilmupemula.Com - Login page yang standart atau bisa dikatakan default dari mikrotik memang sangat kurang menarik bagi para hotspoterz, dalam dunia perhotspotan :D sudah banyak yang membagi turotial untuk mengubah login page hotspot mikrotik yuk mari langsung saja bagaimana cara mengganti login page hotspot mikrotik dengan sangat mudah.

1. Buka winbox
2. Pastikan Hotspot Mikrotik anda sudah jalan, coba akses halaman login hotspot anda di Browser.
Cara Mengganti Login Page Hotspot Mikrotik Dengan Sangat Mudah
Tempat Folder Hotspot
3. Lalu copy file default hotspot kemudian pastekan ke komputer, terlihat halaman html dimana login page hotspot, beginilah penampakan login default mikrotik.
Cara Mengganti Login Page Hotspot Mikrotik Dengan Sangat Mudah
Login Page Default
4. Penampakan folder hotspot yang di copy pada menu file.
Cara Mengganti Login Page Hotspot Mikrotik Dengan Sangat Mudah
Isi file hotspot
5. Kemudian edit file tersebut sesuka selera kita, dapat menggunakan editor dreamweaver, Notepat ++, Dll tapi jangan khawatir dalam postingan ini saya sertakan login page yang Responsive dan Ciamik dan yang paling penting Gratis dan gak ribet untuk downloadya, berikut penampakan ya.
Cara Mengganti Login Page Hotspot Mikrotik Dengan Sangat Mudah
Capture 1

Cara Mengganti Login Page Hotspot Mikrotik Dengan Sangat Mudah
Capture 2
Cara Mengganti Login Page Hotspot Mikrotik Dengan Sangat Mudah
Capture 3
6. Apabila selesai mengedit kemudian copy file hotspot yang sudah di edit tadi, kemudian delet folder hotspot yang lama.

Ada beberapa trouble yang sering terjadi dalam merubah login page mikrotik.
  • Kadang file yang di upload ke mikrotik tidak terupload dengan sempurna yang mengakibatkan size filenya 0 byte.
  • Putus koneksi apabila file edit hotspot terlampau terlalu besar.
  • Router Error, dalam posisi upload sukses akan tetapi ketika router restart maka tampilan login kembali default.
  • Error script index, mengakibatkan tidak dapat login, padahal sudah memasukkan user pass yang benar

Demikian tutorial Cara Mengganti Login Page Hotspot Mikrotik Dengan Sangat Mudah semoga bermanfaat. jangan lupa kunjungi

Tuesday, February 7, 2017

Tutorial Jaringan Cara Membuat Hotspot Menggunakan Mikrotik

Pengertian Hotspot 

imupemula.Com - Hotspot adalah Koneksi jaringan internet yang menggunakan wirelees networking yang biasa nya berada di tempat-tempat umum yang ramai di kunjungi orang, seperti taman,kafe,bandara, ataupun lembaga lembaga pendidikan .

Cara Membuat Hotspot Mikrotik 

Tutorial Jaringan Cara Membuat Hotspot Menggunakan Mikrotik
  1. Tentukan interface yang akan dibuatkan hotspot . disini saya asumsikan menggunakan wlan1. Aktifkan wlan1 dan gunakan mode AP BRIGDE . Isikan SSID  dengan nama hotspot yang anda inginkan.
    Tutorial Jaringan Cara Membuat Hotspot Menggunakan Mikrotik
    Interface Wlan
  2. Berikan IP address interface wlan1,sebagai contoh 192.168.100.1/24 Atau bisa melalui winbox, masuk ke menu IP --> Address. 
    Tutorial Jaringan Cara Membuat Hotspot Menggunakan Mikrotik
    Ip Address
  3. Oke sekarang kita mulai membuat hotspot untuk wlan1. Untuk lebih mudah kita gunakan wizard hotspot setup. Masuk ke menu ip ||hotspot||hotspot setup (perhatikan gambar).
    Tutorial Jaringan Cara Membuat Hotspot Menggunakan Mikrotik
    Hotspot Setup
  4. Pilih hotspot||hotspot setup||pilih wlan1 lalu klik next.
  5. Selanjutnya isi IP address dari wlan1 dan centang Masquerade Network. lalu klik Next.
    Tutorial Jaringan Cara Membuat Hotspot Menggunakan Mikrotik
    Local Address of Network
  6. Menentukan range IP address yang akan diberikan ke user (DHCP Server), misalnya  192.168.100.10-192.168.100.254. Jadi user akan diberikan IP secara otomatis oleh DHCP Server antara range IP tersebut.
    Tutorial Jaringan Cara Membuat Hotspot Menggunakan Mikrotik
    Address Poll
  7. selanjutnya pilih none saja lalu klik next 
    Tutorial Jaringan Cara Membuat Hotspot Menggunakan Mikrotik
    Certificate
  8. IP Address untuk SMTP Server : kosongkan saja lalu klik next.
    Tutorial Jaringan Cara Membuat Hotspot Menggunakan Mikrotik
    SMTP Server
  9. masukan alamat DNS server . isikan dengan DNS server nya Google: 8.8.8.8 dan di bawahnya masukan anggka 8.8.4.4. klik next.
    Tutorial Jaringan Cara Membuat Hotspot Menggunakan Mikrotik
    DNS
  10. Memasukkan nama DNS untuk local hotspot server. Jika diisi nantinya akan menggantikan alamat IP dari wlan1 sebagai url halaman login. Misalkan: Pkl.net , klik next.
    Tutorial Jaringan Cara Membuat Hotspot Menggunakan Mikrotik
    DNS Name
  11. Hotspot sudah berhasil dibuat. Silakan anda coba koneksikan laptop / Handfone anda ke wifi hotspot anda.
    Tutorial Jaringan Cara Membuat Hotspot Menggunakan Mikrotik
    Sample Hotspot
  12. Buka browser dan akses web yang tadi anda buat misal pkl.net atau akses web sembarang, misalnya blogspot.com maka anda akan dialihkan ke halaman login hotspot mikrotik.
    Tutorial Jaringan Cara Membuat Hotspot Menggunakan Mikrotik
    Deault Page Hotspot
  13. Silahkan coba login dengan username admin password kosong , lalu klik ok .
  14. Jika berhasil masuk maka anda berhasil membuat hotspot.
  15. untuk mengedit dan menambahkan user silahkan masuk ke menu IP  Hotspot  klik tab user.  Contoh seperti gambar di bawah.
    Tutorial Jaringan Cara Membuat Hotspot Menggunakan Mikrotik
    User Managemenr

Wednesday, February 1, 2017

Konfigurasi MPLS Mikrotik

ilmupemula.Com - Konfigurasi MPLS Mikrotik  MPLS ini merupakan salat satu fasilitas paket yang disediakan mikrotik dengan menggunakan metode forwarding (meneruskan data/paket melalui suatu jaringan dengan menggunakan informasi label yang ditempelkan pada IP). Sehingga memungkinkan suatu router Akan meneruskan suatu paket dengan hanya melihat label yang melekat pada paket tersebut, sehinggap tidak perlu lagi melihat alamat ip tujuan. 

Prinsip kerja MPLS

Ialah menggabungkan kecepatan change pada layer two dengan kemampuan routing dan skalabilitas pada layer two. Cara kerjanya adalah dengan menyelipkan label di antara header layer two dan layer tree pada paket yang diteruskan. Label dihasilkan oleh Label-Switching Router dimana bertindak sebagai penghubung jaringan MPLS dengan jaringan luar. MPLS meminimalkan routing paket dan mengoptimalkan pilihan jalur (path) yang melalui core network.MPLS juga dapat sebagai multiprotocol karena mampu digunakan lebih sekedar network layer protocol. 

Keuntungan Menggunakan MPLS


Manfaat MPLS ini yaitu untuk jaringan skala luas, yang memerlukan Qos (Quality of service) yang sangat tinggi sehingga meningkatkan SDM dengan didukung dengan jaringan yang mempunyai kualitas baik.

Lab MPLS Mikrotik

Konfigurasi MPLS Mikrotik
Topologi Sederhana MPLS
P1

 /int brid add name=lobridge
/ip address add address=10.255.255.1/32 int=lobridge

P2

 /int brid add name=lobridge
/ip address add address=10.255.255.2/32 int=lobridge

P3

 /int brid add name=lobridge
/ip address add address=10.255.255.3/32 int=lobridge

PE1

/int brid add name=lobridge
/ip address add address=10.255.255.4/32 int=lobridge

PE2

/int brid add name=lobridge
/ip address add address=10.255.255.5/32 int=lobridge

PE3

/int brid add name=lobridge
/ip address add address=10.255.255.6/32 int=lobridge

IP Addressing
kemudian setup link antara router core dan router core-edge sesuai diagram:

P1

/ip address
add address=10.0.255.1/30 int=ether1
add address=10.0.255.5/30 int=ether2
add address=10.1.0.254/24 int=ether3

P2

/ip address
add address=10.0.255.6/30 int=ether1
add address=10.0.255.9/30 int=ether2
add address=10.2.0.254/24 int=ether3

P3

/ip address
add address=10.0.255.10/30 int=ether1
add address=10.0.255.2/30 int=ether2
add address=10.3.0.254/24 int=ether3

PE1

/ip address
add address=10.1.0.1/24 int=ether1
PE2

/ip address
add address=10.2.0.1/24 int=ether1

PE3

/ip address
add address=10.3.0.1/24 int=ether1

Dynamic Routing Setup
Selanjutnya kita bisa men-setup OSPF pada setiap router untuk secara dinamis mendistribusikan rute

P1

/rout ospf instance
set distribute-default=never redistribute-connected=as-type-1 router-id=10.255.255.1
/rout ospf network
add area=backbone network=10.0.255.0/30
add area=backbone network=10.0.255.4/30
add area=backbone network=10.1.0.0/24

P2

/rout ospf instance
set distribute-default=never redistribute-connected=as-type-1 router-id=10.255.255.2
/rout ospf network
add area=backbone network=10.0.255.8/30
add area=backbone network=10.0.255.4/30
add area=backbone network=10.2.0.0/24

P3

/rout ospf instance
set distribute-default=never redistribute-connected=as-type-1 router-id=10.255.255.3
/rout ospf network
add area=backbone network=10.0.255.0/30
add area=backbone network=10.0.255.8/30
add area=backbone network=10.3.0.0/24

PE1

/rout ospf instance
set distribute-default=never redistribute-connected=as-type-1 router-id=10.255.255.4
/rout ospf network
add area=backbone network=10.1.0.0/24

PE2

/rout ospf instance
set distribute-default=never redistribute-connected=as-type-1 router-id=10.255.255.5
/rout ospf network
add area=backbone network=10.2.0.0/24

PE3

/rout ospf instance
set distribute-default=never redistribute-connected=as-type-1 router-id=10.255.255.6
/rout ospf network
add area=backbone network=10.3.0.0/24

MPLS Setup
Langkah selanjutnya adalah menambahkan dan mengkonfigurasi sistem MPLS. Dalam rangka untuk mendistribusikan label untuk rute, LDP harus diaktifkan. Maka semua ints yang ikut dalam MPLS perlu ditambahkan.

P1

/mpls ldp
set enabled=yes lsr-id=10.255.255.1 transport-address=10.255.255.1
/mpls ldp int
add int=ether1
add int=ether2
add int=ether3

P2

/mpls ldp
set enabled=yes lsr-id=10.255.255.2 transport-address=10.255.255.2
/mpls ldp int
add int=ether1
add int=ether2
add int=ether3

P3

/mpls ldp
set enabled=yes lsr-id=10.255.255.3 transport-address=10.255.255.3
/mpls ldp int
add int=ether1
add int=ether2
add int=ether3

PE1

/mpls ldp
set enabled=yes lsr-id=10.255.255.4 transport-address=10.255.255.4
/mpls ldp int
add int=ether1

PE2

/mpls ldp
set enabled=yes lsr-id=10.255.255.5 transport-address=10.255.255.5
/mpls ldp int
add int=ether1

PE3

/mpls ldp
set enabled=yes lsr-id=10.255.255.6 transport-address=10.255.255.6
/mpls ldp int
add int=ether1

Konfigurasi MPLS Mikrotik
Konfigurasi MPLS Mikrotik Via Winbox
loading...

Labels